Jump to content
Compvision.ru

Wade

Пользователи
  • Content count

    4
  • Joined

  • Last visited

Community Reputation

0 Новичек

About Wade

  • Rank
    Новичок
  1. А куда именно копать? Камеру можно завесить каким то рандомным набором байт? Просто по утечки - камера не работает сразу после перезагрузки - там и память то не кушается. Такое ощущение, что при внезапном завершении программы зависает камера. Причем это случается на свежих процессорах intel g3250,а на моем core i7 или на соседнем старом пентиуме такого нет Толи уменьшить скорость обработки кадров, то ли как то завершать работу с камерой?
  2. void FrameShow::run(){ bool open = cap.open(-1); if ((cap.isOpened())&&(open)) { cap.set(cv::CAP_PROP_FRAME_WIDTH,1280); cap.set(cv::CAP_PROP_FRAME_HEIGHT,720); qDebug()<<cap.get(cv::CAP_PROP_FRAME_WIDTH); qDebug()<<cap.get(cv::CAP_PROP_FRAME_HEIGHT); for(;;) { cap >> img; //cv::cvtColor(img,gray,cv::COLOR_RGB2GRAY); //perspMat = cv::getPerspectiveTransform(p[0],p[1]); QImage res = QImage((const unsigned char*)(img.data),img.cols,img.rows,img.step,QImage::Format_RGB888); emit newImage(res); } } } Открывается камера и постоянно идет вызов передается картинка в слот
  3. Друзья, с моим вопросом может кто-нибудь что подсказать?) Я уже поставил и на отдельную pci-express usb плату espada. Результат тот же самый. Перезагрузки не выдерживает(((
  4. Добрый вечер. У меня проблема с opencv+linux+logitech c920 Имеется софт, который работает с вебкамерой. Камера постоянна включена( logitech920) Программа на Qt, операционка Ubuntu 14.04, opencv 3.0 Программа показывает постоянно изображение и может применять фильтр opengl к получившейся картинке. И я столкнулся с такой проблемой - при долгой работе или при перезагрузке после работы - камера пропадает из системы. Т.е. работает программа, показывает картинку, перезагружаем, бывает показывает, а бывает нет. Либо просто долго работает, и зависает В lsusb камеры нет. Помогает только либо выдергивание камеры из юсб, либо выключение компьютера и отрубание питания. Работает в режиме 1280 на 720 Появляется в основном на клиентских терминалах - там стоят матплаты на свежем чипсете h81. У меня на машине разработчика более старая мать и таких проблем я не наблюдал, пока не попало в боевой режим клиентам Пробывал уже разные варианты и usb2 и usb3. И плату расширения usb3 с отдельным питанием. Итог один и тот же - камера отваливается наглухо либо после перезагрузки рандомно, либо после длительной работы. Может быть кто сталкивался? В какую сторону копать? Поможет ли умешение разрешения до 640 на 480, например? Какие еще возможны варианты? ПС камер и терминалов попробовал штук 20 - везде такие симптомы Заранее спасибо
×